package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:https?:\/\/)?(?:www\.)?plus\.google\.com\/([\w]+\/)?([\d]\/)?([+]?[\w(\_\-)?p{L}]+|[\d]{21})(?:\/)?(?:[\w(\-\_)?]+)?`)
var str = `https://plus.google.com/+google/posts"
, "https://plus.google.com/+google/about"
, "https://plus.google.com/+google/photos"
, "https://plus.google.com/+google/videos"
, "https://plus.google.com/+google/plusones"
, "https://plus.google.com/+google/reviews"
, "https://plus.google.com/asdasda/104645458102703754878"
, "https://plus.google.com/u/0/LONGIDHE-RE"
, "https://plus.google.com/u/0/+JoseManuelGarcĂa_ertatto"
https://plus.google.com/b/101789019230490914475/101789019230490914475/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}