#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?| # two alternatives whose group numbers both begin at 1" & @CRLF & _
" \\autocites # match the command" & @CRLF & _
" (?|\{([^}]*)\}|\[([^]]*)\])" & @CRLF & _
" # and a parameter in group 1" & @CRLF & _
"| # OR" & @CRLF & _
" \G # anchor the match to the end of the last match" & @CRLF & _
" (?|\{([^}]*)\}|\[([^]]*)\])" & @CRLF & _
" # and match a parameter in group 1" & @CRLF & _
")" & @CRLF & _
" "
Local $sString = "\autocites[a][b]{c}[d][e]{f}[a][a]{a}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")