import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?| # two alternatives whose group numbers both begin at 1\n"
+ " \\\\autocites # match the command\n"
+ " (?|\\{([^\\}]*)\\}|\\[([^]]*)\\])\n"
+ " # and a parameter in group 1\n"
+ "| # OR\n"
+ " \\G # anchor the match to the end of the last match\n"
+ " (?|\\{([^\\}]*)\\}|\\[([^]]*)\\])\n"
+ " # and match a parameter in group 1\n"
+ ")\n"
+ " ";
final String string = "\\autocites[a][b]{c}[d][e]{f}[a][a]{a}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}