const regex = /(?| # two alternatives whose group numbers both begin at 1
\\autocites # match the command
(?|\{([^}]*)\}|\[([^]]*)\])
# and a parameter in group 1
| # OR
\G # anchor the match to the end of the last match
(?|\{([^}]*)\}|\[([^]]*)\])
# and match a parameter in group 1
)
/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?| # two alternatives whose group numbers both begin at 1
\\\\autocites # match the command
(?|\\{([^}]*)\\}|\\[([^]]*)\\])
# and a parameter in group 1
| # OR
\\G # anchor the match to the end of the last match
(?|\\{([^}]*)\\}|\\[([^]]*)\\])
# and match a parameter in group 1
)
', 'g')
const str = `\\autocites[a][b]{c}[d][e]{f}[a][a]{a}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}