re = /(?| # two alternatives whose group numbers both begin at 1
\\autocites # match the command
(?|\{([^}]*)\}|\[([^]]*)\])
# and a parameter in group 1
| # OR
\G # anchor the match to the end of the last match
(?|\{([^}]*)\}|\[([^]]*)\])
# and match a parameter in group 1
)
/x
str = '\\autocites[a][b]{c}[d][e]{f}[a][a]{a}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end