package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?| # two alternatives whose group numbers both begin at 1
\\autocites # match the command
(?|\{([^}]*)\}|\[([^]]*)\])
# and a parameter in group 1
| # OR
\G # anchor the match to the end of the last match
(?|\{([^}]*)\}|\[([^]]*)\])
# and match a parameter in group 1
)
`)
var str = `\autocites[a][b]{c}[d][e]{f}[a][a]{a}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}