# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^Code = (\w+).+$/\1/gm;t' <<< "Code = ABCD123 | Points = 30
Code = ABCD333 | Points = 44
"