package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Code = (\w+).+$`)
var str = `Code = ABCD123 | Points = 30
Code = ABCD333 | Points = 44
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}