#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^Code = (\w+).+$"
Local $sString = "Code = ABCD123 | Points = 30" & @CRLF & _
"Code = ABCD333 | Points = 44" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)