$re = '/^Code = (\w+).+$/m';
$str = 'Code = ABCD123 | Points = 30
Code = ABCD333 | Points = 44
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;