re = /^Code = (\w+).+$/m
str = 'Code = ABCD123 | Points = 30
Code = ABCD333 | Points = 44
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result