using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)<ftype>.*?</ftype>[\r\n]*";
string substitution = @"";
string input = @"<xml>
<EType>
<E></E>
<F></F>
<FType><E1></E1><E2></E2></FType>
<FType><E1></E1><E2></E2></FType>
<FType><E1></E1><E2></E2></FType>
<G></G>
</EType>
</xml>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}