package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<ftype>.*?</ftype>[\r\n]*`)
var str = `<xml>
<EType>
<E></E>
<F></F>
<FType><E1></E1><E2></E2></FType>
<FType><E1></E1><E2></E2></FType>
<FType><E1></E1><E2></E2></FType>
<G></G>
</EType>
</xml>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}