# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)<ftype>.*?</ftype>[\r\n]*"
test_str = ("<xml>\n"
"<EType>\n"
"<E></E>\n"
"<F></F>\n"
"<FType><E1></E1><E2></E2></FType>\n"
"<FType><E1></E1><E2></E2></FType>\n"
"<FType><E1></E1><E2></E2></FType>\n"
"<G></G>\n"
"</EType>\n"
"</xml>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.