import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)<ftype>.*?</ftype>[\\r\\n]*";
final String string = "<xml>\n"
+ "<EType>\n"
+ "<E></E>\n"
+ "<F></F>\n"
+ "<FType><E1></E1><E2></E2></FType>\n"
+ "<FType><E1></E1><E2></E2></FType>\n"
+ "<FType><E1></E1><E2></E2></FType>\n"
+ "<G></G>\n"
+ "</EType>\n"
+ "</xml>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}