#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)6[5-9]|[78]\d|9[0789]|1[01]\d|12[012]"
Local $sString = "1234567" & @CRLF & _
"12345C" & @CRLF & _
"" & @CRLF & _
"3456789" & @CRLF & _
"345CY" & @CRLF & _
"" & @CRLF & _
"9865432" & @CRLF & _
"bA432" & @CRLF & _
"" & @CRLF & _
"6566676869707172737475767778798081828384858687888990" & @CRLF & _
"ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"" & @CRLF & _
"6711110010100071111108102" & @CRLF & _
"Code000Golf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")