# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"6[5-9]|[78]\d|9[0789]|1[01]\d|12[012]"
test_str = ("1234567\n"
"12345C\n\n"
"3456789\n"
"345CY\n\n"
"9865432\n"
"bA432\n\n"
"6566676869707172737475767778798081828384858687888990\n"
"ABCDEFGHIJKLMNOPQRSTUVWXYZ\n\n"
"6711110010100071111108102\n"
"Code000Golf")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.