import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "6[5-9]|[78]\\d|9[0789]|1[01]\\d|12[012]";
final String string = "1234567\n"
+ "12345C\n\n"
+ "3456789\n"
+ "345CY\n\n"
+ "9865432\n"
+ "bA432\n\n"
+ "6566676869707172737475767778798081828384858687888990\n"
+ "ABCDEFGHIJKLMNOPQRSTUVWXYZ\n\n"
+ "6711110010100071111108102\n"
+ "Code000Golf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}