# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.{8,32}$)(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[(!@#$%^&*)]).*//gm;t' <<< "Asdfh)uk
Asdfh)u6k
Asdfh)u6kiuythgfrtdfgvcsdertyuio
fahsfhas098
gahsgjags097jA!"