using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{8,32}$)(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[(!@#$%^&*)]).*";
string substitution = @"";
string input = @"Asdfh)uk
Asdfh)u6k
Asdfh)u6kiuythgfrtdfgvcsdertyuio
fahsfhas098
gahsgjags097jA!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}