#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=.{8,32}$)(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[(!@#$%^&*)]).*"
Local $sString = "Asdfh)uk" & @CRLF & _
"Asdfh)u6k" & @CRLF & _
"Asdfh)u6kiuythgfrtdfgvcsdertyuio" & @CRLF & _
"fahsfhas098" & @CRLF & _
"gahsgjags097jA!"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)