re = /^(?=.{8,32}$)(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[(!@#$%^&*)]).*/m
str = 'Asdfh)uk
Asdfh)u6k
Asdfh)u6kiuythgfrtdfgvcsdertyuio
fahsfhas098
gahsgjags097jA!'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result