$re = '/^(?=.{8,32}$)(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[(!@#$%^&*)]).*/m';
$str = 'Asdfh)uk
Asdfh)u6k
Asdfh)u6kiuythgfrtdfgvcsdertyuio
fahsfhas098
gahsgjags097jA!';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;