import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:\\S+\\s+){4})";
final String string = "EE84 1484.74 1364.99 62.5 2 1 0 1 \n"
+ "EE85 505.23 841.63 60. 2 1 0 1 \n"
+ "EE86 945.95 913.39 100. 1 0 0 0 \n"
+ "P3 972.44 1126.12 100. 1 0 0 0 \n"
+ "P28 980.0 1119.0 100. 1 0 0 0 \n"
+ "P100 964.03 1125.93 100. 1 0 0 0 \n"
+ "P102 963.49 1133.71 100. 1 0 0 0 \n"
+ "P106 974.06 1150.73 100. 1 0 0 0 \n"
+ "P108 1017.36 1062.47 100. 1 0 0 0 \n"
+ "P109 965.31 1151.14 100. 1 0 0 0 ";
final String subst = "${1}0 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}