# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:\S+\s+){4})"
test_str = ("EE84 1484.74 1364.99 62.5 2 1 0 1 \n"
"EE85 505.23 841.63 60. 2 1 0 1 \n"
"EE86 945.95 913.39 100. 1 0 0 0 \n"
"P3 972.44 1126.12 100. 1 0 0 0 \n"
"P28 980.0 1119.0 100. 1 0 0 0 \n"
"P100 964.03 1125.93 100. 1 0 0 0 \n"
"P102 963.49 1133.71 100. 1 0 0 0 \n"
"P106 974.06 1150.73 100. 1 0 0 0 \n"
"P108 1017.36 1062.47 100. 1 0 0 0 \n"
"P109 965.31 1151.14 100. 1 0 0 0 ")
subst = "${1}0 "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.