#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)Host: (.*?)<br>"
Local $sString = "<span style="font-weight: bold;"> Problem started at 15:14:06 on" & @CRLF & _
"2022.06.16<br>" & @CRLF & _
"Problem name: Site is Down!<br>" & @CRLF & _
"Host: worldbells.com<br>" & @CRLF & _
"Severity: Average<br>" & @CRLF & _
"Operational data: 100 %<br>" & @CRLF & _
"Original problem ID: <br>" & @CRLF & _
" </span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")