use strict;
my $str = '<span style="font-weight: bold;"> Problem started at 15:14:06 on
2022.06.16<br>
Problem name: Site is Down!<br>
Host: worldbells.com<br>
Severity: Average<br>
Operational data: 100 %<br>
Original problem ID: <br>
</span>';
my $regex = qr/Host: (.*?)<br>/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}