// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)Host: (.*?)<br>").unwrap();
let string = "<span style=\"font-weight: bold;\"> Problem started at 15:14:06 on
2022.06.16<br>
Problem name: Site is Down!<br>
Host: worldbells.com<br>
Severity: Average<br>
Operational data: 100 %<br>
Original problem ID: <br>
</span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}