#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?="_id"\s*:)(?&key_value)" & @CRLF & _
"" & @CRLF & _
"(?(DEFINE)" & @CRLF & _
" (?<string_inner>(?<=["])(?>[^"\\]++|[\\].)++(?=["]))" & @CRLF & _
" (?<string>["](?&string_inner)?+["])" & @CRLF & _
" (?<object>[{]\s*+(?&key_values)?+\s*+[}])" & @CRLF & _
" (?<array>\[\s*+(?&values)?+\s*+\])" & @CRLF & _
" (?<key_values>(?&key_value)(?>\s*+[,]\s*+(?&key_value))*+)" & @CRLF & _
" (?<key_value>(?&string)\s*+[:]\s*+(?&value))" & @CRLF & _
" (?<number>[-]?+\d++(?>[.]\d++)?+(?>[Ee][+-]?+\d++)?+)" & @CRLF & _
" (?<bool>true|false)" & @CRLF & _
" (?<scalar>(?&bool)|(?&number)|(?&string)|null)" & @CRLF & _
" (?<value>(?&scalar)|(?&object)|(?&array))" & @CRLF & _
" (?<values>(?&value)(?>\s*+[,]\s*+(?&value))*+)" & @CRLF & _
")"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "_id": "56af331efbeca6240c61b2ca"," & @CRLF & _
" "index": 120000," & @CRLF & _
" "guid": "bedb2018-c017-429E-b520-696ea3666692"," & @CRLF & _
" "isActive": false," & @CRLF & _
" "balance": "$2,202,350"," & @CRLF & _
" "object": {" & @CRLF & _
" "name": "alexander"," & @CRLF & _
" "lastname": "lang"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")