import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\"_id\"\\s*:)(?&key_value)\n\n"
+ "(?(DEFINE)\n"
+ " (?<string_inner>(?<=[\"])(?>[^\"\\\\]++|[\\\\].)++(?=[\"]))\n"
+ " (?<string>[\"](?&string_inner)?+[\"])\n"
+ " (?<object>[\\{]\\s*+(?&key_values)?+\\s*+[\\}])\n"
+ " (?<array>\\[\\s*+(?&values)?+\\s*+\\])\n"
+ " (?<key_values>(?&key_value)(?>\\s*+[,]\\s*+(?&key_value))*+)\n"
+ " (?<key_value>(?&string)\\s*+[:]\\s*+(?&value))\n"
+ " (?<number>[-]?+\\d++(?>[.]\\d++)?+(?>[Ee][+-]?+\\d++)?+)\n"
+ " (?<bool>true|false)\n"
+ " (?<scalar>(?&bool)|(?&number)|(?&string)|null)\n"
+ " (?<value>(?&scalar)|(?&object)|(?&array))\n"
+ " (?<values>(?&value)(?>\\s*+[,]\\s*+(?&value))*+)\n"
+ ")";
final String string = "[\n"
+ " {\n"
+ " \"_id\": \"56af331efbeca6240c61b2ca\",\n"
+ " \"index\": 120000,\n"
+ " \"guid\": \"bedb2018-c017-429E-b520-696ea3666692\",\n"
+ " \"isActive\": false,\n"
+ " \"balance\": \"$2,202,350\",\n"
+ " \"object\": {\n"
+ " \"name\": \"alexander\",\n"
+ " \"lastname\": \"lang\"\n"
+ " }\n"
+ " }\n"
+ "]\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}