$re = '/(?="_id"\s*:)(?&key_value)
(?(DEFINE)
(?<string_inner>(?<=["])(?>[^"\\\\]++|[\\\\].)++(?=["]))
(?<string>["](?&string_inner)?+["])
(?<object>[{]\s*+(?&key_values)?+\s*+[}])
(?<array>\[\s*+(?&values)?+\s*+\])
(?<key_values>(?&key_value)(?>\s*+[,]\s*+(?&key_value))*+)
(?<key_value>(?&string)\s*+[:]\s*+(?&value))
(?<number>[-]?+\d++(?>[.]\d++)?+(?>[Ee][+-]?+\d++)?+)
(?<bool>true|false)
(?<scalar>(?&bool)|(?&number)|(?&string)|null)
(?<value>(?&scalar)|(?&object)|(?&array))
(?<values>(?&value)(?>\s*+[,]\s*+(?&value))*+)
)/mx';
$str = '[
{
"_id": "56af331efbeca6240c61b2ca",
"index": 120000,
"guid": "bedb2018-c017-429E-b520-696ea3666692",
"isActive": false,
"balance": "$2,202,350",
"object": {
"name": "alexander",
"lastname": "lang"
}
}
]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);