use strict;
my $str = '[
{
"_id": "56af331efbeca6240c61b2ca",
"index": 120000,
"guid": "bedb2018-c017-429E-b520-696ea3666692",
"isActive": false,
"balance": "$2,202,350",
"object": {
"name": "alexander",
"lastname": "lang"
}
}
]
';
my $regex = qr/(?="_id"\s*:)(?&key_value)
(?(DEFINE)
(?<string_inner>(?<=["])(?>[^"\\]++|[\\].)++(?=["]))
(?<string>["](?&string_inner)?+["])
(?<object>[{]\s*+(?&key_values)?+\s*+[}])
(?<array>\[\s*+(?&values)?+\s*+\])
(?<key_values>(?&key_value)(?>\s*+[,]\s*+(?&key_value))*+)
(?<key_value>(?&string)\s*+[:]\s*+(?&value))
(?<number>[-]?+\d++(?>[.]\d++)?+(?>[Ee][+-]?+\d++)?+)
(?<bool>true|false)
(?<scalar>(?&bool)|(?&number)|(?&string)|null)
(?<value>(?&scalar)|(?&object)|(?&array))
(?<values>(?&value)(?>\s*+[,]\s*+(?&value))*+)
)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}