using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=""_id""\s*:)(?&key_value)
(?(DEFINE)
(?<string_inner>(?<=[""])(?>[^""\\]++|[\\].)++(?=[""]))
(?<string>[""](?&string_inner)?+[""])
(?<object>[{]\s*+(?&key_values)?+\s*+[}])
(?<array>\[\s*+(?&values)?+\s*+\])
(?<key_values>(?&key_value)(?>\s*+[,]\s*+(?&key_value))*+)
(?<key_value>(?&string)\s*+[:]\s*+(?&value))
(?<number>[-]?+\d++(?>[.]\d++)?+(?>[Ee][+-]?+\d++)?+)
(?<bool>true|false)
(?<scalar>(?&bool)|(?&number)|(?&string)|null)
(?<value>(?&scalar)|(?&object)|(?&array))
(?<values>(?&value)(?>\s*+[,]\s*+(?&value))*+)
)";
string input = @"[
{
""_id"": ""56af331efbeca6240c61b2ca"",
""index"": 120000,
""guid"": ""bedb2018-c017-429E-b520-696ea3666692"",
""isActive"": false,
""balance"": ""$2,202,350"",
""object"": {
""name"": ""alexander"",
""lastname"": ""lang""
}
}
]
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}