using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"in\/(.+?)\/";
string input = @"http://foo.com/do/front-end-development/in/london/at/realise/";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}