$re = '/in\/(.+?)\//i';
$str = 'http://foo.com/do/front-end-development/in/london/at/realise/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);