package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)in\/(.+?)\/`)
var str = `http://foo.com/do/front-end-development/in/london/at/realise/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}