const regex = /in\/(.+?)\//i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('in\\\/(.+?)\\\/', 'i')
const str = `http://foo.com/do/front-end-development/in/london/at/realise/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}