re = /in\/(.+?)\//i
str = 'http://foo.com/do/front-end-development/in/london/at/realise/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end