using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+),";
string input = @"IPswitch-E-WiFi,csv,m2-0Ja,___EV_IB,0000,0001, 937456,0000000006, 0,0002169122, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121,00,00,00,00,00,00,00,00,00,00,00000,2A61 ,243";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}