re = /(.+),/m
str = 'IPswitch-E-WiFi,csv,m2-0Ja,___EV_IB,0000,0001, 937456,0000000006, 0,0002169122, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121,00,00,00,00,00,00,00,00,00,00,00000,2A61 ,243'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end