use strict;
my $str = 'IPswitch-E-WiFi,csv,m2-0Ja,___EV_IB,0000,0001, 937456,0000000006, 0,0002169122, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121, 0,0002169121,00,00,00,00,00,00,00,00,00,00,00000,2A61 ,243';
my $regex = qr/(.+),/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}