#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((25[0-5])|(2[0-4]?\d?)|(1\d{1,2}?)|([1-9]\d?)|([1-9]))\.){3}((25[0-5])|(2[0-4]?\d?)|(1\d{1,2}?)|([1-9]\d?)|([1-9]))$"
Local $sString = "111" & @CRLF & _
"000" & @CRLF & _
"256" & @CRLF & _
"333" & @CRLF & _
"222" & @CRLF & _
"267" & @CRLF & _
"1.1.1.1" & @CRLF & _
"255.255.255.255" & @CRLF & _
"000.000.000.000" & @CRLF & _
"0.0.0.0" & @CRLF & _
"100.28.28.1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")