using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((25[0-5])|(2[0-4]?\d?)|(1\d{1,2}?)|([1-9]\d?)|([1-9]))\.){3}((25[0-5])|(2[0-4]?\d?)|(1\d{1,2}?)|([1-9]\d?)|([1-9]))$";
string input = @"111
000
256
333
222
267
1.1.1.1
255.255.255.255
000.000.000.000
0.0.0.0
100.28.28.1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}