import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((25[0-5])|(2[0-4]?\\d?)|(1\\d{1,2}?)|([1-9]\\d?)|([1-9]))\\.){3}((25[0-5])|(2[0-4]?\\d?)|(1\\d{1,2}?)|([1-9]\\d?)|([1-9]))$";
final String string = "111\n"
+ "000\n"
+ "256\n"
+ "333\n"
+ "222\n"
+ "267\n"
+ "1.1.1.1\n"
+ "255.255.255.255\n"
+ "000.000.000.000\n"
+ "0.0.0.0\n"
+ "100.28.28.1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}