// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((25[0-5])|(2[0-4]?\d?)|(1\d{1,2}?)|([1-9]\d?)|([1-9]))\.){3}((25[0-5])|(2[0-4]?\d?)|(1\d{1,2}?)|([1-9]\d?)|([1-9]))$").unwrap();
let string = "111
000
256
333
222
267
1.1.1.1
255.255.255.255
000.000.000.000
0.0.0.0
100.28.28.1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}