const regex = /^(((25[0-5])|(2[0-4]?\d?)|(1\d{1,2}?)|([1-9]\d?)|([1-9]))\.){3}((25[0-5])|(2[0-4]?\d?)|(1\d{1,2}?)|([1-9]\d?)|([1-9]))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((25[0-5])|(2[0-4]?\\d?)|(1\\d{1,2}?)|([1-9]\\d?)|([1-9]))\\.){3}((25[0-5])|(2[0-4]?\\d?)|(1\\d{1,2}?)|([1-9]\\d?)|([1-9]))$', 'gm')
const str = `111
000
256
333
222
267
1.1.1.1
255.255.255.255
000.000.000.000
0.0.0.0
100.28.28.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}