#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:https?:\/\/(?:www\.)?|https:(?:\/\/)?)?\w+(?:[-.]\w+)+(?:\/[^\/\s]+)*$"
Local $sString = "So based on the criteria, these should pass:" & @CRLF & _
"" & @CRLF & _
"http://www.google.com" & @CRLF & _
"google.com" & @CRLF & _
"abc.def.ghi/hij" & @CRLF & _
"https:216.239.38.120" & @CRLF & _
"216.239.38.120" & @CRLF & _
"These should not pass:" & @CRLF & _
"" & @CRLF & _
"hello" & @CRLF & _
"hello/world" & @CRLF & _
"abc://def.ghi" & @CRLF & _
"ftp:google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")