const regex = /^(?:https?:\/\/(?:www\.)?|https:(?:\/\/)?)?\w+(?:[-.]\w+)+(?:\/[^\/\s]+)*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/(?:www\\.)?|https:(?:\\\/\\\/)?)?\\w+(?:[-.]\\w+)+(?:\\\/[^\\\/\\s]+)*$', 'gmi')
const str = `So based on the criteria, these should pass:
http://www.google.com
google.com
abc.def.ghi/hij
https:216.239.38.120
216.239.38.120
These should not pass:
hello
hello/world
abc://def.ghi
ftp:google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}