import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/(?:www\\.)?|https:(?:\\/\\/)?)?\\w+(?:[-.]\\w+)+(?:\\/[^\\/\\s]+)*$";
final String string = "So based on the criteria, these should pass:\n\n"
+ "http://www.google.com\n"
+ "google.com\n"
+ "abc.def.ghi/hij\n"
+ "https:216.239.38.120\n"
+ "216.239.38.120\n"
+ "These should not pass:\n\n"
+ "hello\n"
+ "hello/world\n"
+ "abc://def.ghi\n"
+ "ftp:google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}