// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:https?:\/\/(?:www\.)?|https:(?:\/\/)?)?\w+(?:[-.]\w+)+(?:\/[^\/\s]+)*$").unwrap();
let string = "So based on the criteria, these should pass:
http://www.google.com
google.com
abc.def.ghi/hij
https:216.239.38.120
216.239.38.120
These should not pass:
hello
hello/world
abc://def.ghi
ftp:google.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}